<!doctype html >
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head>
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-137962985-1"></script>
    <script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-137962985-1');
    </script>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
	<!--<title>TechCentral.ie | Ireland&#039;s technology news resource</title>-->
    <title>What’s new in Rust 1.45 - TechCentral.ie</title>
	
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
	
<!-- This site is optimized with the Yoast SEO plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.techcentral.ie/VJW8o" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What’s new in Rust 1.45 - TechCentral.ie" />
<meta property="og:description" content="The unique approach of the&nbsp;Rust programming language&nbsp;results in better code with fewer compromises than C, C++, Go, and the other languages you probably use. It also gets updated regularly, often every month. If you already have a previous version of Rust installed via&nbsp;rustup, you can access the latest version via the following command: $ rustup [&amp;hellip" />
<meta property="og:url" content="http://www.techcentral.ie/VJW8o" />
<meta property="og:site_name" content="TechCentral.ie" />
<meta property="article:publisher" content="https://www.facebook.com/TechCentral.ie" />
<meta property="article:tag" content="developers" />
<meta property="article:tag" content="languages" />
<meta property="article:tag" content="Rust" />
<meta property="article:tag" content="Rust 1.45" />
<meta property="article:section" content="Pro" />
<meta property="article:published_time" content="2020-07-21T08:45:00+01:00" />
<meta property="article:modified_time" content="2020-07-21T09:33:10+01:00" />
<meta property="og:updated_time" content="2020-07-21T09:33:10+01:00" />
<meta property="og:image" content="https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS.jpg" />
<meta property="og:image:secure_url" content="https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="413" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The unique approach of the&nbsp;Rust programming language&nbsp;results in better code with fewer compromises than C, C++, Go, and the other languages you probably use. It also gets updated regularly, often every month. If you already have a previous version of Rust installed via&nbsp;rustup, you can access the latest version via the following command: $ rustup [&amp;hellip" />
<meta name="twitter:title" content="What’s new in Rust 1.45 - TechCentral.ie" />
<meta name="twitter:site" content="@techcentral_ie" />
<meta name="twitter:image" content="https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS.jpg" />
<meta name="twitter:creator" content="@techcentral_ie" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//readitlaterlist.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TechCentral.ie &raquo; Feed" href="https://www.techcentral.ie/feed/" />
<link rel="alternate" type="application/rss+xml" title="TechCentral.ie &raquo; Comments Feed" href="https://www.techcentral.ie/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.techcentral.ie\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='flick-css'  href='https://www.techcentral.ie/wp-content/plugins/mailchimp//css/flick/flick.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='https://www.techcentral.ie/?mcsf_action=main_css&#038;ver=5.4.2' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://www.techcentral.ie/wp-content/plugins/mailchimp/css/ie.css?ver=5.4.2' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='main_css-css'  href='https://www.techcentral.ie/wp-content/themes/shelflifegonzo/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.techcentral.ie/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='mediateam-newsletter-generator-css'  href='https://www.techcentral.ie/wp-content/plugins/mediateam-newsletter-generator/public/css/mediateam-newsletter-generator-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='frontierpost-css'  href='https://www.techcentral.ie/wp-content/plugins/frontier-post/frontier-post.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-slick-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/slick.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-bxslider-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/jquery.bxslider.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-font-awesome-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/font-awesome.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-tooltipster-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/tooltipster.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-custom-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/custom.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='lcpro-style-css'  href='https://www.techcentral.ie/wp-content/plugins/logo-carousel-pro/public/assets/css/style.min.css?ver=3.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='page-list-style-css'  href='https://www.techcentral.ie/wp-content/plugins/sitemap/css/page-list.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.techcentral.ie/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.1' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background: #E53D3C;
	border: 1px solid #E53D3C;
}

</style>
<link rel='stylesheet' id='addtoany-css'  href='https://www.techcentral.ie/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='mfgigcal_css-css'  href='https://www.techcentral.ie/wp-content/plugins/mf-gig-calendar/css/mf_gig_calendar.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var gonzo_script = {"post_id":"138450","ajaxurl":"https:\/\/www.techcentral.ie\/wp-admin\/admin-ajax.php"};
var gonzo_script = {"post_id":"138450","ajaxurl":"https:\/\/www.techcentral.ie\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mailchimp/js/scrollTo.js?ver=1.5.2'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"https:\/\/www.techcentral.ie\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mailchimp/js/mailchimp.js?ver=1.5.2'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mailchimp//js/datepicker.js?ver=5.4.2'></script>
<script type='text/javascript' src='http://readitlaterlist.com/button/multi_v1.js'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/themes/shelflifegonzo/js/libs/modernizr-2.0.6.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/themes/shelflifegonzo/js/scripts.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mediateam-newsletter-generator/public/js/mediateam-newsletter-generator-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='https://www.techcentral.ie/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.techcentral.ie/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.techcentral.ie/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.techcentral.ie/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.techcentral.ie/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize = {
	Share: "Share",
	Save: "Save",
	Subscribe: "Subscribe",
	Email: "Email",
	Bookmark: "Bookmark",
	ShowAll: "Show All",
	ShowLess: "Show less",
	FindServices: "Find service(s)",
	FindAnyServiceToAddTo: "Instantly find any service to add to",
	PoweredBy: "Powered by",
	ShareViaEmail: "Share via email",
	SubscribeViaEmail: "Subscribe via email",
	BookmarkInYourBrowser: "Bookmark in your browser",
	BookmarkInstructions: "Press Ctrl+D or \u2318+D to bookmark this page",
	AddToYourFavorites: "Add to your favourites",
	SendFromWebOrProgram: "Send from any email address or email program",
	EmailProgram: "Email program",
	More: "More&#8230;",
	ThanksForSharing: "Thanks for sharing!",
	ThanksForFollowing: "Thanks for following!"
};

(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<!-- This site is using AdRotate v4.13.2 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
		<style type="text/css">

		.pocket_read_it_later {
		float: right;
margin: 0px 0px 10px 15px;		}

		</style>
			<!-- Shortn.It version 1.7.4 -->
	<link rel="shorturl" href="http://www.techcentral.ie/VJW8o">
	<link rel="shortlink" href="http://www.techcentral.ie/VJW8o">
	<!-- End Shortn.It -->
<link rel="icon" href="https://www.techcentral.ie/wp-content/uploads/2018/10/TC-Fav-50x50.png" sizes="32x32" />
<link rel="icon" href="https://www.techcentral.ie/wp-content/uploads/2018/10/TC-Fav-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.techcentral.ie/wp-content/uploads/2018/10/TC-Fav-186x186.png" />
<meta name="msapplication-TileImage" content="https://www.techcentral.ie/wp-content/uploads/2018/10/TC-Fav-300x300.png" />
	<!--[if IE 10]><link rel="stylesheet" type="text/css" media="all" href="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/css/ie10.css" /><![endif]-->
	<!--[if IE 9]><link rel="stylesheet" type="text/css" media="all" href="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/css/ie9.css" /><![endif]-->
	<!--[if IE 8]><link rel="stylesheet" type="text/css" media="all" href="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/css/ie8.css" /><![endif]-->
	<!--[if IE 7]><link rel="stylesheet" type="text/css" media="all" href="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/css/ie7.css" /><![endif]-->
	<link href='http://fonts.googleapis.com/css?family=Oswald:400,700' rel='stylesheet' type='text/css'>
	<link href='http://fonts.googleapis.com/css?family=Lato:400,700' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/includes/fontkit/font-awesome/css/font-awesome.min.css">
	<link href='http://fonts.googleapis.com/css?family=:400italic,700italic,400,700' rel='stylesheet' type='text/css'>

	
<style>
	.es-carousel ul{display:block;}

    #signup {
		font-family:/*'LucidaSansStd', */arial;
        position: absolute;
        z-index:100;
        top: 0px;
        left: 0px;
        height: auto;
        background: #fff;
		border-top:5px solid #000;
		border-bottom:5px solid #000;
		box-shadow:0 0 8px #000;
        display: none;
		padding:20px 16px;
	color:#000 !important;
     }
	#signup p { color:#000 !important }
	#signup span { padding:5px; color:#fff; font-weight:bold;}
	#signup span.civil {background: #EAA23C;}
	#signup span.home  { background: #221F20 }
	#signup span.chem { background: #30707E }
	#signup span.mech  { background: #582E65 }
	#signup span.tech { background: #839743 }
	#signup span.bio{ background: #E06B3E }
	#signup span.elec { background: #A53847 }
	#signup span.general{ background: #3D5057 }

    #lean_overlay { position: fixed; z-index:100; top: 0; left: 0; height:100%; width:100%;  background: #000; display: none;}
</style>


	



<style>/* Put your custom css in here  */

#fsb-social-bar {
margin-top:20px !important;
}

#mc_mv_FNAME, #mc-indicates-required {
display: none !important;
}
.navigation .alignleft a, .navigation .alignright a{background-color: rgb(249, 156, 28); color: rgb(255, 255, 255); padding:5px 7px;}
.navigation .alignleft a:hover, .navigation .alignright a:hover{background: #5e5b52;}

.mc_form_inside::after{clear:both;}

@media only screen and (max-width: 480px) { /*Remove background for 320px displays*/
	div#omc-transparent-layer {background:none;}
	body {background:none;}
}

body {font-size:;}
</style>

    			<script type="text/javascript" src="http://platform.linkedin.com/in.js"></script>

<script type="text/javascript" >
		jQuery(document).ready(function($) {
			var a = $('#shareit div').html();
			var b = $('#shareitTop ul').html(a);
			var c = $('#shareitBottom ul').html(a);
			$("#shareitBottom ul").prepend("<li style='color: #333; font-size: 16px; font-weight: bold; margin-right:0; position: relative; top: -50px;'>Share: </li>");
  		});

		jQuery(document).ready(function($) {
			var a = $('#addsContainer img').html();
			$("#addsContainer img").attr('width', '100%');
			$("#addsContainer img").attr('height', 'auto');
  		});

		// Image Margins based on floats
		jQuery(document).ready(function($) {
$("img[align='left']").css('margin', '0 10px 10px 0');
$("img[align='right']").css('margin', '0 0 10px 10px');
  		});



		// Move MPU on smaller screens from the RHS to after the 5th paragraph
		jQuery(document).ready(function ($) {
			if ($(window).width() < 750) {

				$("#omc-full-article p:eq(5)").addClass('widget_text');
		  		var copyover = 	$("div.MPUFromHere").appendTo("#omc-full-article p:eq(5)");
				//alert(copyover);
				$("#omc-full-article p:eq(5) img").css('margin-top' ,"20px");
    		}
	      		else {
          		// alert('More than 960');
      		}
		});
  </script>





    <!--MailChimpPopUp-->
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/cfbee37636e85a964dc7a8cf4/f33af882bcc54fa1c2b453dcf.js");</script>

<!--MailChimpPopUp-->
<style>
</style>


</head>

<body class="post-template-default single single-post postid-138450 single-format-standard pro" >

<!-- Test Strap to be removed -->

<div class="topBanner" >
  <div id="text-8" class="omc-footer-widget widget_text">			<div class="textwidget"><div class="g g-1">
<div class="g-single a-255"><a class="gofollow" data-track="MjU1LDEsMSw2MA==" href="https://www.ics.ie/training/certified-cyber-security-risk-officer-programme" target="_blank" rel="noopener noreferrer"><img src="https://www.techcentral.ie/wp-content/uploads/2020/05/ICS_CyberRisk_May20_728x90.gif" /></a></div>
</div>
</div>
		</div><div id="text-7" class="omc-footer-widget widget_text">			<div class="textwidget"><div class="g g-3">
<div class="g-single a-90"><a class="gofollow" data-track="OTAsMywxLDYw" href="https://www.ics.ie/training/certificate-in-business-analysis" target="_blank" rel="noopener noreferrer"><img src="https://www.techcentral.ie/wp-content/uploads/2019/01/BA-online-ad-280-90.gif" /></a></div>
</div>
</div>
		</div><div id="custom_html-2" class="widget_text omc-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"></div></div></div>

<h1></h1>

	<div id="fb-root">
	</div>
	<script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0];  if (d.getElementById(id)) return;  js = d.createElement(s); js.id = id;  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";  fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>

	<div id="omc-transparent-layer">

	<!-- <div class="preloaders" style=""></div>  -->

		
		<div id="omc-container">

      <header>


				<div id="socialbox-2" class="omc-top-banner">


	
		
		<a href="http://feeds.feedburner.com//kco/LvLF" title="Subscribe to Feed" class="omc-social-media-icon large" target="_blank">
			<span class="omc-Feedburner omc-icon"><span></span></span>
			<span class="omc-following-info">0<br /><strong>Subscribers</strong></span>				
		</a>			
	
		
		<a href="http://www.facebook.com/TechCentral.ie" title="Like on Facebook" class="omc-social-media-icon large" target="_blank">
			<span class="omc-Facebook omc-icon"><span></span></span>
			<span class="omc-following-info">0<br /><strong>Fans</strong></span>				
		</a>			
	
		
		<a href="http://twitter.com/techcentral_ie" title="Follow on Twitter" class="omc-social-media-icon large no-right" target="_blank">
			<span class="omc-Twitter omc-icon"><span></span></span>
			<span class="omc-following-info">0<br /><strong>Followers</strong></span>				
		</a>			
	
		
		<a href="https://www.linkedin.com/groups/2921804" title="Follow on LinkedIn" class="omc-social-media-icon large" target="_blank">
			<span class="omc-Digg omc-icon"><span></span></span>
			<span class="omc-following-info">0<br /><strong>Followers</strong></span>				
		</a>			
	
		
	
	<br class="clear" />		
			
</div><div id="search-2" class="omc-top-banner"><div class="omc-sidebar-search">
		
		<form method="get" id="omc-main-search" action="https://www.techcentral.ie/">
			
			<fieldset>
			
				<label class="hidden" for="s"></label>
				
				<input type="text" class="search_input_sidebar" value="Search..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" name="s" id="s" />
				
				<input type="submit" class="search_button_sidebar" id="searchsubmit" value="Go &rarr;" />
			
			</fieldset>
			
		</form>
		
</div><!-- /omc-sidebar-search --></div>			<ul id="topLogin" >
                 <li class="first" ><a href="/about">About</a></li>
                 <li><a href="/contact">Contact</a></li>
                 <li ><a href="/advertise/">Advertise</a></li>
                 <li ><a href="/techpro-magazine/">TechPro magazine</a></li>
                 <li class="tpl-li"><a href="#">ComputerScope</a></li>
                 <li class="tpl-li"><a href="#"> Irish Computer</a></li>

                 <a class="id_a" href="http://www.techcentral.ie/login/">Log in</a> 				 <!--  | <a href="/wp-register.php">Register</a> -->
			</ul>
				<a id="omc-logo" href="https://www.techcentral.ie"><img src="https://www.techcentral.ie/wp-content/themes/gonzo/images/logo.png" alt="TechCentral.ie logo" height="118" /></a>


                <div id="shareitTop">
                	<ul>
                    </ul>
                </div>
                <!--<div id="shareitTopCover" style="height:50px; display:none;"></div>-->
		<div id="shareitTopCover">
<div id="sl-css">

		<a title="Subscribe to Feed" class="omc-social-media-icon large" href="https://feeds.feedburner.com//kco/LvLF" target="_blank">
			<span class="omc-Feedburner omc-icon"><span></span></span>
			<span class="omc-following-info">0<br><strong>Subscribers</strong></span>
		</a>


		<a title="Like on Facebook" class="omc-social-media-icon large" href="https://www.facebook.com/TechCentral.ie" target="_blank">
			<span class="omc-Facebook omc-icon"><span style="opacity: 1;"></span></span>
			<span class="omc-following-info">135<br><strong>Fans</strong></span>
		</a>


		<a title="Follow on Twitter" class="omc-social-media-icon large no-right" href="https://twitter.com/techcentral_ie" target="_blank">
			<span class="omc-Twitter omc-icon"><span></span></span>
			<span class="omc-following-info">0<br><strong>Followers</strong></span>
		</a>


		<a title="Follow on LinkedIn" class="omc-social-media-icon large" href="https://www.linkedin.com/groups/TechCentralie-2921804?home=&amp;gid=2921804&amp;trk=anet_ug_hm" target="_blank">
			<span class="omc-Digg omc-icon"><span></span></span>
			<span class="omc-following-info">0<br><strong>Followers</strong></span>
		</a>


	</div>
	<br class="clear">	</div>
<!-- shareing icons end -->

             	<br class="clear">
			
				<nav id="omc-main-navigation">
						<div class="omc-over-480"><ul id="menu-main-menu" class="menu"><li id='menu-item-958'  class="civil menu-item menu-item-type-taxonomy menu-item-object-category"><a  title="TechLife" href="https://www.techcentral.ie/category/life/" id="5fbb47">TechLife</a> <small class="nav_desc">5fbb47</small></li>
<li id='menu-item-122635'  class="chem menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a  href="https://www.techcentral.ie/category/pro/" id="f99c1c">TechPro</a> <small class="nav_desc">f99c1c</small></li>
<li id='menu-item-957'  class="mech menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://www.techcentral.ie/category/trade/" id="4883c4">TechTrade</a> <small class="nav_desc">4883c4</small></li>
<li id='menu-item-960'  class="tech menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://www.techcentral.ie/category/radio/" id="9a4f9e">TechRadio</a> <small class="nav_desc">9a4f9e</small></li>
<li id='menu-item-125648'  class="elec beat menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://www.techcentral.ie/category/beat/" id="a53847">TechBeat</a> <small class="nav_desc">a53847</small></li>
<li id='menu-item-129780'  class="civil menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://www.techcentral.ie/category/blogs/" id="Opinion and analysys of current trends in technology">Blogs</a> <small class="nav_desc">Opinion and analysys of current trends in technology</small></li>
<li id="omc-header-search">				
						<span id="omc-search-overlay">Search &rarr;</span>
						<form method="get" id="desktop-search" class="omc-search-form" action="https://www.techcentral.ie/">
							<input type="text" class="omc-header-search-input-box" value=""  name="s" id="fffff">
							<input type="submit" class="omc-header-search-button" id="searchsubmit" value="">
						</form>
					</li></ul></div>
					
					<br class="clear" />

					<div class="omc-under-480"><select id="omc-mobile-menu"><option value="#">Navigation</option><option value="https://www.techcentral.ie/category/life/">TechLife</option><option value="https://www.techcentral.ie/category/pro/">TechPro</option><option value="https://www.techcentral.ie/category/trade/">TechTrade</option><option value="https://www.techcentral.ie/category/radio/">TechRadio</option><option value="https://www.techcentral.ie/category/beat/">TechBeat</option></select></div>
					<div id="omc-header-search-mobi">

						<form method="get" id="mobi-search" class="omc-mobi-search-form" action="https://www.techcentral.ie/">

							<input type="text" class="omc-header-mobi-search-input-box" value=""  name="s" id="mobi-mobi-search">

							<input type="submit" class="omc-header-mobi-search-button" id="seadssdrchsubmit" value="">

						</form>
					</div>
								</nav>
			<br class="clear" />

			</header><!--ShelfLifeGonzo-Single.php-->
        <section id="omc-main">	

            <article id="omc-full-article" class="omc-inner-standard">
            <h1 class="omc-post-heading-standard">What’s new in Rust 1.45</h1>

                
        
                    <div id="omc-inner-placeholder2">
								<div class="articleImg" >
									                                        <img src="https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS.jpg" class="featured-top wp-post-image" alt="" srcset="https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS.jpg 620w, https://www.techcentral.ie/wp-content/uploads/2016/09/Rust_corrosion_steeel_decay_IDGNS-300x200.jpg 300w" sizes="(max-width: 315px) 100vw, 315px" />                                                                            
                                    <div >
									<span class="wp-caption-text">(Image: IDGNS)</span>                                    </div>
                                </div>
								<div class="articleDetails" >
                                
                                                                                                            <p class="storyIntro">Designed to make it easy to develop fast and safe system-level software, Rust gets new developments</p>
                                        
                                    
                                <p id="readItLater"><span class="pocket_read_it_later"><script type="text/javascript">
			RIL_button( "https://www.techcentral.ie/whats-new-in-rust-1-45/", "What’s new in Rust 1.45" );
		</script></span> <a id="printButton" href="javascript:window.print()">Print</a></p>
                                
                                <a style=" display:none;"href="javascript:window.print()"><img src="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/images/print.gif" alt="Print" />Print</a>
                                
                                                                        
                                    
                                    
                                </div>

                        <a href="https://www.techcentral.ie/category/pro/" class="omc-flex-category">Pro</a>
                    </div><!-- /omc-inner-placeholder -->
                    
                    <div style="clear:both"></div>
                    <p class="omc-single-tags"><b>Read More:</b> <a href="https://www.techcentral.ie/tag/developers/" rel="tag">developers</a>  <a href="https://www.techcentral.ie/tag/languages/" rel="tag">languages</a>  <a href="https://www.techcentral.ie/tag/rust/" rel="tag">Rust</a>  <a href="https://www.techcentral.ie/tag/rust-1-45/" rel="tag">Rust 1.45</a><br /></p>
                        <div class="omc-article-top2">
                            <p class="omc-date-time-inner omc-format-standard">
                                21 July 2020 | 
                            <span class="omc-comment-count">0</span></p>
                        </div>
                        <!-- /omc-article-top2-->

                
                    <p>The unique approach of the&nbsp;<a href="https://www.infoworld.com/article/3218074/what-is-rust-safe-fast-and-easy-software-development.html">Rust programming language</a>&nbsp;results in better code with fewer compromises than C, C++, Go, and the other languages you probably use. It also gets updated regularly, often every month.</p>
<p>If you already have a previous version of Rust installed via&nbsp;<code>rustup</code>, you can access the latest version via the following command:</p>
<pre class="wp-block-preformatted">$ rustup update stable</pre>
<p>Get up to speed quickly on newcomer Rust, designed to create fast, system-level software. This two-minute animated explainer shows how Rust bypasses the vexing programming issues of memory and management.</p>
<div class="g g-4">
<div class="g-single a-89"> </p>
<p><center>advertisement</p>
<p><span style="background-color:#FFFFFF;
outline: 2px solid black;
outline-offset: 15px;"><a class="gofollow" data-track="ODksNCwxLDYw" href="https://www.ics.ie/training/certificate-in-business-analysis" target="_blank"><img src="https://www.techcentral.ie/wp-content/uploads/2019/01/BA-online-ad-300-250.gif" /></a></span><br />
</center><br />
 </div>
</div>
<h2>New in Rust 1.45.0</h2>
<p>Announced on 16 July, 2020, Rust 1.45 includes the following additions and improvements:</p>
<ul>
<li>A fix is offered to mend some longstanding unsoundness when casting between integers and floats.</li>
<li>Stabilisation is offered for function-like procedural macros in expressions, patterns, and statements. Expansion of the use of macros assists with use of the Rocket web framework for Rust.</li>
<li>Several library APIs have been stabilised, such as&nbsp;<code>Arc::as_ptr</code>,&nbsp;<code>BTreeMap::remove_entry</code>, and&nbsp;<code>Span::resolved_at</code>. The full list of APIs can be found in the&nbsp;<a href="https://blog.rust-lang.org/2020/07/16/Rust-1.45.0.html" target="_blank" rel="noreferrer noopener">Rust Blog</a>.</li>
</ul>
<h2>Rust 1.43.1</h2>
<p>This point release was introduced 7 May, 2020, to address two regressions introduced in the 1.43.0 stable release. It also updates the OpenSSL version used by the Cargo package manager. Features include:</p>
<ul>
<li>Rust 1.27 introduced support for detecting x86 CPU features in the standard library, via the&nbsp;<code>is_x86_feature_detected</code>&nbsp;macro. Because of an internal refactoring, Rust 1.43.0 prevented detection of features that cannot be used on stable yet, even though detecting them previously was allowed. Version 1.43.1 fixes this regression.</li>
<li>A fix is offered for broken&nbsp;<code>cargo package –list</code>&nbsp;command. Rust 1.43 broke support for listing files included in packages published with Cargo, when executed inside a workspace with path dependencies or unpublished versions.</li>
<li>OpenSSL, a Cargo dependency, has been updated to 1.1.1g. OpenSSL had released a&nbsp;<a href="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1967" target="_blank" rel="noreferrer noopener">security advisory</a>&nbsp;but the Rust team was not able to include the fix in time for Rust 1.43.0. The team has no evidence the vulnerability could compromise Cargo users’ security.</li>
</ul>
<h2>New in Rust 1.43.0</h2>
<p>Announced 23 April, 2020, Rust 1.43.0 was considered a fairly minor release, with no major features introduced. Changes include:</p>
<ul>
<li>Developers can use&nbsp;<code>item</code>&nbsp;fragments to interpolate items into the body of&nbsp;<code>trait</code>,&nbsp;<code>impl</code>, and&nbsp;<code>extern</code>&nbsp;blocks.</li>
<li>The type inference around primitives, references, and binary operations was improved.</li>
<li>To help integration testing, Cargo will set some new&nbsp;<a href="https://github.com/rust-lang/cargo/pull/7697" target="_blank" rel="noreferrer noopener">environment variables</a>&nbsp;for tests to find executables.</li>
<li>In the Rust library, developers can use&nbsp;<a href="https://github.com/rust-lang/rust/pull/68952/" target="_blank" rel="noreferrer noopener">associated constants</a>&nbsp;on floats and integers directly without having to import the module. Also, there is a new&nbsp;<code>primitive</code>&nbsp;module that re-exports Rust primitive types, which is useful when writing a macro and developers want to ensure types are not shadowed.</li>
<li>Several APIs in the library were stabilised:&nbsp;<code>Once::is_completed</code>,&nbsp;<code>f32::LOG10_2</code>,&nbsp;<code>f32::LOG2_10</code>,&nbsp;<code>f32::LOG10_2</code>,&nbsp;<code>f64::LOG10_2</code>,&nbsp;<code>f64::LOG2_10</code>, and&nbsp;<code>iter::once_with</code>.</li>
</ul>
<h2>New in Rust 1.41</h2>
<p>Version 1.41.0, announced 30 January, 2020, contains the following new features and improvements:</p>
<ul>
<li>Restrictions are relaxed when implementing traits. Prior to Rust 1.41.0, the orphan rule was unnecessarily strict, obstructing composition. The rule was enforced to prevent breakages when a dependency adds a new trait,&nbsp;<code>impl</code>, with the gist being that a trait&nbsp;<code>impl</code>&nbsp;was only permitted if either the trait or the type being implemented is local to the current crate as opposed to a foreign crate.</li>
<li><code>cargo install</code>, for installing binary crates and Rust-based CLI tools, now will update existing installations of the crate if a new release has been published.</li>
<li>For lock files, which are used to ensure consistent builds, a new format is introduced to avoid unnecessary merge conflicts when changing dependencies in separate branches. The new format will be used for all new lock files while existing lock files still rely on the previous format.</li>
<li>More guarantees are offered when using a&nbsp;<code>Box&lt;T&gt;</code>&nbsp;in FFI (Foreign Function Interface).&nbsp;<code>Box&lt;T&gt;</code>, referred to as a box, provides Rust’s simplest form of heap allocation. If developers have an&nbsp;<code>extern</code>&nbsp;“C” Rust function, called from C, the Rust function now can use&nbsp;<code>Box&lt;T&gt;</code>&nbsp;for some specific&nbsp;<code>T</code>, while using&nbsp;<code>T*</code>&nbsp;in C for the corresponding function. However, developers for now should avoid using&nbsp;<code>Box&lt;T&gt;</code>&nbsp;types for functions that are defined in C but invoked in Rust. In these cases, developers should directly mirror the C types as closely as possible.</li>
<li>Additions to the library were made, such as stabilising the&nbsp;<code>Result::map_or</code>&nbsp;and&nbsp;<code>Result:map_or_else</code>. Also stabilised were the&nbsp;<code>weak_count</code>&nbsp;and&nbsp;<code>strong_count</code>&nbsp;methods.&nbsp;<code>NonZero*</code>&nbsp;numerics now implement&nbsp;<code>From&lt;NonZero*&gt;</code>&nbsp;if it is a smaller integer width.</li>
<li>Rust 1.41.0 will be the&nbsp;last version&nbsp;with the current level of compiler support for 32-bit Apple targets.</li>
</ul>
<h2>New in Rust 1.40</h2>
<p>Rust version 1.40, released in December 2019, contained the following improvements and changes:</p>
<ul>
<li>It is now possible to allow macros to themselves generate macros. This allows for far more sophisticated metaprogramming using Rust than was previously possible, except perhaps by manual code generation. It’s now also possible to use procedural macros to define types, and to use them in&nbsp;<code>extern</code>&nbsp;blocks. And the new&nbsp;<code>todo!()</code>&nbsp;macro can be used in place of the more verbose&nbsp;<code>unimplemented!()</code>.</li>
<li>A new attribute,&nbsp;<code>#[non_exhaustive]</code>, lets you decorate a type to indicate it might have more fields or other changes in the future. This keeps other code from overriding the definition or using it as part of an exhaustive pattern match, which might break unexpectedly later on when the type is changed.</li>
<li>Code that would have compiled under the old borrow checker, but generates a warning under the new borrow checker, will now generate hard errors. This is both to encourage cleanup of older Rust code and to allow the old borrow checker code to be phased out entirely.</li>
<li>Several new compiler targets have been added, such as ARM’s Thumb-2 Neon (version 7) and MIPS64 platforms that use the&nbsp;<code>musl</code>&nbsp;lightweight standard library.</li>
</ul>
<h2>New in Rust 1.38</h2>
<p>Rust 1.38, released in September 2019, contains the following new features and improvements:</p>
<ul>
<li>The Cargo package manager will take advantage of pipelined compilation automatically with Rust 1.38. With pipelined compilation, the compiler does not need dependencies fully built when compiling a crate. All that is needed is their metadata, such as the list of types of dependencies. Metadata is produced early in the compilation process. Some tests have shown compilation speed increases of 10 to 20 percent for optimised, clean builds of some crate graphs.&nbsp;</li>
<li>Linting of some incorrect uses of&nbsp;<code>mem::{unitialized, zeroed}</code>. With this release, the rustc compiler will provide a lint for a narrow class of incorrect initialisations using&nbsp;<code>mem::uninitialized or mem::zeroed</code>.</li>
<li>Extension of the&nbsp;<code>#[deprecated]</code>&nbsp;attribute to macros. This attribute has allowed crate authors to notify users that an item of their crate is to be deprecated and removed in a future release.</li>
<li>Developers can use&nbsp;<code>std::any::type_name</code>&nbsp;to get the name of a type.</li>
<li>Stabilisation of a number of functions including&nbsp;<code>&lt;*const T&gt;::cast</code>&nbsp;and&nbsp;<code>&lt;*mutT&gt;::cast</code>.</li>
</ul>
<h2>New in Rust 1.37</h2>
<p>Rust 1.37, released in August 2019, has the following new features and improvements:</p>
<ul>
<li>An ability to refer to&nbsp;<code>enum</code>&nbsp;variants through&nbsp;<code>type</code>. Developers also can refer to&nbsp;<code>enum</code>&nbsp;variants with&nbsp;<code>Self::Variant</code>.</li>
<li>The&nbsp;<code>cargo vendor</code>&nbsp;command, previously a separate crate, is now built in to the language. The command fetches project dependencies, unpacks them into the vendor<strong>/&nbsp;</strong>directory, and displays the configuration snippet needed to use the vendored code during builds.</li>
<li>The&nbsp;<code>rustc</code>&nbsp;compiler supports profile-guided optimisation, an optimising technique for ahead-of-time compilers, via&nbsp;<code>-C profile-generate</code>&nbsp;and&nbsp;<code>-C profile-use</code>.</li>
<li>Developers can create unnamed&nbsp;<code>const</code>&nbsp;items.</li>
</ul>
<h2>New in Rust 1.36</h2>
<p>Version 1.36 of the Rust systems programming language was released in July 2019. Rust 1.36 includes the following new features and enhancements:</p>
<ul>
<li>The&nbsp;<a href="https://doc.rust-lang.org/std/future/trait.Future.html" target="_blank" rel="noreferrer noopener">Future trait</a>, used for declaring asynchronous work, is now stable. Asynchronous operations in Rust have been coming together in bits and pieces for several versions now, with&nbsp;<code>async</code>&nbsp;and&nbsp;<code>await</code>&nbsp;being the last important remaining pieces.</li>
<li>The&nbsp;<a href="https://doc.rust-lang.org/alloc/index.html" target="_blank" rel="noreferrer noopener">alloc crate</a>, used for managing memory, is now stable. This crate collects all of the pieces of Rust’s standard library that depend on a global memory allocation mechanism, such as&nbsp;<code>Vec&lt;T&gt;</code>. This way, crates that don’t use the standard library can still make use of the allocator by importing alloc separately—useful for environments where you want code sizes to be as lean as possible.</li>
<li>A new type,&nbsp;<code><a href="https://doc.rust-lang.org/std/mem/union.MaybeUninit.html">MaybeUninit&lt;T&gt;</a></code>, allows you to define objects that may consist of uninitialised memory, such as a lazily allocated array. Rust’s previous mechanism for doing this was a function,&nbsp;<code>mem::uninitialized</code>, that posed many hazards in casual use.&nbsp;<code>MaybeUninit&lt;T&gt;</code>&nbsp;provides a safer way to do this that uses the constraints of Rust’s type system.</li>
<li><a href="http://blog.pnkfx.org/blog/2019/06/26/breaking-news-non-lexical-lifetimes-arrives-for-everyone/" target="_blank" rel="noreferrer noopener">Non-lexical lifetimes</a>, a feature for recent editions of Rust, has been backported to earlier editions. Non-lexical lifetimes make Rust’s borrow-checking mechanism less difficult to work with (in essence, letting you write a broader range of programs that are still valid Rust), and better able to catch problems that the borrow checker missed.</li>
</ul>
<p>Other improvements:</p>
<ul>
<li>A new implementation for the&nbsp;<code>HashMap&lt;K, V&gt;</code>&nbsp;type that runs faster and uses less memory.</li>
<li>Cargo can now run entirely offline if needed.</li>
</ul>
<h2>New in Rust 1.35</h2>
<p>Version 1.35,&nbsp;<a href="https://blog.rust-lang.org/2019/05/23/Rust-1.35.0.html" target="_blank" rel="noreferrer noopener">released in May 2019</a>, offers the following:</p>
<ul>
<li>Implementation of the&nbsp;<code>FnOnce</code>,&nbsp;<code>FnMut</code>, and&nbsp;<code>Fn</code>&nbsp;closure traits for&nbsp;<code>Box&lt;dyn FnOnce&gt;</code>,&nbsp;<code>Box&lt;dyn FnMut&gt;</code>, and&nbsp;<code>Box&lt;dyn Fn&gt;</code>.</li>
<li>The&nbsp;<code>dbg!</code>&nbsp;macro introduced in Rust 1.32 now can be called without arguments.</li>
<li>Fn* closure traits now are implemented for&nbsp;<code>Box&lt;dyn Fn*&gt;</code>.</li>
<li>Stabilisations of the standard library.</li>
<li>Clippy, providing a collection of lints to catch common mistakes, added a lint,&nbsp;<code>drop_bounds</code>, which is triggered when adding a bound&nbsp;<code>T: Drop</code>&nbsp;to a generic function.</li>
<li>A&nbsp;<code>ptr::hash</code>&nbsp;function has been introduced, so developers can avoid hashing the pointed-to value of a reference and instead hash the address.</li>
<li>The value of a&nbsp;<code>RefCell</code>&nbsp;can be replaced through a closure. Developers can more ergonomically map and replace the current value of the cell and retrieve the old value.</li>
<li>Developers now can easily check whether a value exists in a range.</li>
<li>A number of changes have been made to the&nbsp;<a rel="noreferrer noopener" href="https://github.com/rust-lang/cargo/blob/master/CHANGELOG.md#cargo-135-2019-05-23" target="_blank">Cargo</a>, such as the addition of a&nbsp;<code>rustc-cdylib-link-arg</code>&nbsp;key for build scripts to specify linker arguments for cdylib crates.</li>
</ul>
<p><em>IDG News Service</em></p>
</p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom">
<div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.techcentral.ie/whats-new-in-rust-1-45/" data-a2a-><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_plusone addtoany_special_service" data-href="https://www.techcentral.ie/whats-new-in-rust-1-45/"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_button_slashdot" href="https://www.addtoany.com/add_to/slashdot?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.techcentral.ie%2Fwhats-new-in-rust-1-45%2F&amp;linkname=What%E2%80%99s%20new%20in%20Rust%201.45"  rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div>
</div>


                     
                    
                    	




                
                
			<div class="link_pages"></div>
				
               <div id="shareitBottom" >
                	<ul>
                    </ul>
                </div>


                        <p class="omc-single-tags"><b>Read More:</b> <a href="https://www.techcentral.ie/tag/developers/" rel="tag">developers</a>  <a href="https://www.techcentral.ie/tag/languages/" rel="tag">languages</a>  <a href="https://www.techcentral.ie/tag/rust/" rel="tag">Rust</a>  <a href="https://www.techcentral.ie/tag/rust-1-45/" rel="tag">Rust 1.45</a><br /></p>

    
        <br class="clear"/>

       
        <nav id="nav-single" class="omc-related-posts" >
            <h3 class="assistive-text">More Articles</h3>
            <span class="nav-previous"><a href="https://www.techcentral.ie/new-swift-project-handles-server-app-start-up-shutdown/" rel="prev"><span class="meta-nav">&larr;</span> Previous</a></span>
            <span class="nav-next" style="float:right"><a href="https://www.techcentral.ie/deep-learning-and-etl-for-the-jvm/" rel="next">Next <span class="meta-nav">&rarr;</span></a></span>
            <br />
        </nav><!-- #nav-single -->

        <div class="omc-related-posts"  >


            <h4 >Related Articles</h4>
                            
                            <article class="omc-related-post omc-module-c omc-quarter-width-category category-5">

                                <a href="https://www.techcentral.ie/new-swift-project-handles-server-app-start-up-shutdown/" title="New Swift project handles server app start-up, shutdown">

                                    <img src="https://www.techcentral.ie/wp-content/uploads/2017/08/Apple_Swift_logo_web-290x166.jpg" class="omc-image-resize wp-post-image" alt="" />
                                </a>

                                <h5 class="omc-related-article"><a href="https://www.techcentral.ie/new-swift-project-handles-server-app-start-up-shutdown/"
                                                                   title="New Swift project handles server app start-up, shutdown">New Swift project handles server app start-up, shutdown</a><span> &rarr;</span>
                                </h5>

                            </article><!-- /omc-related-post -->

            
                            <article class="omc-related-post omc-module-c omc-quarter-width-category category-5">

                                <a href="https://www.techcentral.ie/r-language-rises-with-covid-19-research/" title="R language rises with Covid-19 research">

                                    <img src="https://www.techcentral.ie/wp-content/uploads/2019/08/code-3337044_960_720-290x166.jpg" class="omc-image-resize wp-post-image" alt="coding programming" />
                                </a>

                                <h5 class="omc-related-article"><a href="https://www.techcentral.ie/r-language-rises-with-covid-19-research/"
                                                                   title="R language rises with Covid-19 research">R language rises with Covid-19 research</a><span> &rarr;</span>
                                </h5>

                            </article><!-- /omc-related-post -->

            
                        <br class="clear"/>

                                
        </div><!-- /omc-related-posts -->
        
        

        <br class="clear"/>

        
        

    
			<div id="comments">

	<p class="nocomments">Comments are closed.</p>



</div><!-- #comments -->


    </article><!-- /omc-full-article -->

</section><!-- /omc-main -->

<section id="omc-sidebar" class="omc-right">

	<a href="#top" class="omc-mobile-back-to-top">Back to Top &uarr;</a>

	
	
	<ul class="xoxo">
		<li id="mc4wp_form_widget-2" class="omc-widget widget_mc4wp_form_widget"><h3 class="widgettitle"><span>Sign up for Techcentral.ie</span></h3><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.5.0 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-132527" method="post" data-id="132527" data-name="Sign up for Techcentral.ie" ><div class="mc4wp-form-fields"><div id="mc_subheader">
			Stay on top of the day's tech news with our free <strong>Technology Minute</strong> e-mail newsletter - just add your e-mail here		</div>

<div class="mc_merge_var">
	
	<input type="text" name="EMAIL" placeholder="E-mail" class="mc_input" />
</div>

<div class="mc_signup_submit">
	<input type="submit" value="" id="mc_signup_submit" class="button" />
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1595335102" /><input type="hidden" name="_mc4wp_form_id" value="132527" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></li><li id="text-60" class="omc-widget widget_text"><h3 class="widgettitle"><span>Support our advertisers</span></h3>			<div class="textwidget"><div class="g g-2">
<div class="g-single a-196"><centre><a class="gofollow" data-track="MTk2LDIsMSw2MA==" href="https://www.iptelecom.ie/?utm_campaign=techpro_nl&#038;utm_source=email&#038;utm_content=techpro_static" target="_blank" rel="noopener noreferrer"><img src="https://www.techcentral.ie/wp-content/uploads/2020/01/IPTelecom_300x250.jpg" /></a></centre></div>
</div>
</div>
		</li><li id="text-61" class="omc-widget widget_text">			<div class="textwidget"><p><a href="http://www.techcentral.ie/wp-content/uploads/2018/09/zzz.png"><img src="https://www.techcentral.ie/wp-content/uploads/2018/09/zzz.png" alt="" class="alignnone size-full wp-image-129881" /></a></p>
</div>
		</li><li id="gigcalendarwidget-3" class="omc-widget widget_gigcalendarwidget"><h3 class="widgettitle"><span>Events</span></h3>
<ul id="mfgigcal-widget">
<li><div class="date">Sun 19 Jul&ndash;Thu 23 Jul <span class="time"></span></div>
<h4><a href="http://techcentral.ie/events?event_id=1143">MS-700T00 Managing Microsoft Teams</a></h4><p>New Horizons Ireland</p></li>
<li><div class="date">Mon 20 Jul&ndash;Fri 24 Jul <span class="time"></span></div>
<h4><a href="http://techcentral.ie/events?event_id=1202">AZ-204T00-A: Developing Solutions for Microsoft Azure</a></h4><p>New Horizons, Dublin</p></li>
</ul>

<p><a href="http://techcentral.ie/events" class="calendar_url">View All Events</a></p></li><li id="text-57" class="omc-widget widget_text">			<div class="textwidget"><p><a class="submit-event" href="http://www.techcentral.ie/event-submission/">Submit Your Event</a></p>
</div>
		</li><li id="text-31" class="omc-widget widget_text">			<div class="textwidget"><div class="g g-2">
<div class="g-single a-199"><centre><a class="gofollow" data-track="MTk5LDIsMSw2MA==" href="https://www.contractingplus.com/" target="_blank" rel="noopener noreferrer"><img src="https://www.techcentral.ie/wp-content/uploads/2020/02/ContractingPlus_300x250_.gif" /></a></centre></div>
</div>
</div>
		</li><li id="text-53" class="omc-widget widget_text">			<div class="textwidget"><h4>A-Z Brand index</h4>
<p><a href="https://www.techcentral.ie/a-z-brand-index/">Click here to go to our index for resellers to source brands and determine who distributes them locally.</a></p>
</div>
		</li>	
        
        
        
             
        
        
        
        
    <li id="categoryposts-3" class="omc-widget widget_categoryposts" >  
        <h3 class="widgettitle"><span>More from this Channel </span></h3>  
        <ul >
                    <li class="cat-post-item category-news">
                <a class="post-title" href="https://www.techcentral.ie/twitter-statement-reveals-hack-details/">Twitter statement reveals hack details</a>
                <p><a href="https://www.techcentral.ie/twitter-statement-reveals-hack-details/">2FA defeated in social engineering attack</a></p>
            </li>
                    <li class="cat-post-item category-news">
                <a class="post-title" href="https://www.techcentral.ie/deep-learning-and-etl-for-the-jvm/">Deep learning and ETL for the JVM</a>
                <p><a href="https://www.techcentral.ie/deep-learning-and-etl-for-the-jvm/">Deeplearning4j offers a stack of components for building JVM-based applications that incorporate AI</a></p>
            </li>
                    <li class="cat-post-item category-news">
                <a class="post-title" href="https://www.techcentral.ie/whats-new-in-rust-1-45/">What’s new in Rust 1.45</a>
                <p><a href="https://www.techcentral.ie/whats-new-in-rust-1-45/">Designed to make it easy to develop fast and safe system-level software, Rust gets new developments</a></p>
            </li>
                    <li class="cat-post-item category-news">
                <a class="post-title" href="https://www.techcentral.ie/new-swift-project-handles-server-app-start-up-shutdown/">New Swift project handles server app start-up, shutdown</a>
                <p><a href="https://www.techcentral.ie/new-swift-project-handles-server-app-start-up-shutdown/">Swift Service Lifecycle is an open source project aimed at supporting the language’s server ecosystem</a></p>
            </li>
                    <li class="cat-post-item category-news">
                <a class="post-title" href="https://www.techcentral.ie/calls-for-unified-cybersecurity-strategy-in-a-post-covid-world/">Calls for unified cybersecurity strategy in a post-Covid world</a>
                <p><a href="https://www.techcentral.ie/calls-for-unified-cybersecurity-strategy-in-a-post-covid-world/">Agile Networks webinar session will appeal to CIOs, CISOs,  infosec professionals</a></p>
            </li>
                </ul>
    </li>   
		
        <!--<li><div class="g g-3"><div class="g-single a-254"><a class="gofollow" data-track="MjU0LDMsMSw2MA==" href="https://www.ics.ie/training/certified-cyber-security-risk-officer-programme" target="_blank"><img src="https://www.techcentral.ie/wp-content/uploads/2020/05/ICS_CyberRisk_May20_285x90.gif" /></a></div></div></li>-->		

	</ul><!-- /xoxo -->





</section>	

<br class="clear" />
	
</div> <!--! end of #container -->



<div class="topBanner">
        <div id="text-8" class="omc-footer-widget widget_text">
		<div class="textwidget"><p>	<div class="g g-1"><div class="g-single a-255"><a class="gofollow" data-track="MjU1LDEsMSw2MA==" href="https://www.ics.ie/training/certified-cyber-security-risk-officer-programme" target="_blank"><img src="https://www.techcentral.ie/wp-content/uploads/2020/05/ICS_CyberRisk_May20_728x90.gif" /></a></div></div></p>
</div>
		</div><div id="text-7" class="omc-footer-widget widget_text">			<div class="textwidget"><p><div class="g g-3"><div class="g-single a-90"><a class="gofollow" data-track="OTAsMywxLDYw" href="https://www.ics.ie/training/certificate-in-business-analysis" target="_blank"><img src="https://www.techcentral.ie/wp-content/uploads/2019/01/BA-online-ad-280-90.gif" /></a></div></div></p>
</div>
		</div>
</div>

<footer id="omc-boxed">
    <div class="footerTags">
            </div><!--- /second-footer-column -->

    <div class="footerLinks" >
        <div class="omc-copyright-menu"><ul id="menu-main-menu-1" class="menu"><li id="menu-item-958" class="civil menu-item menu-item-type-taxonomy menu-item-object-category menu-item-958"><a title="TechLife" href="https://www.techcentral.ie/category/life/">TechLife</a></li>
<li id="menu-item-122635" class="chem menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-122635"><a href="https://www.techcentral.ie/category/pro/">TechPro</a></li>
<li id="menu-item-957" class="mech menu-item menu-item-type-taxonomy menu-item-object-category menu-item-957"><a href="https://www.techcentral.ie/category/trade/">TechTrade</a></li>
<li id="menu-item-960" class="tech menu-item menu-item-type-taxonomy menu-item-object-category menu-item-960"><a href="https://www.techcentral.ie/category/radio/">TechRadio</a></li>
<li id="menu-item-125648" class="elec beat menu-item menu-item-type-taxonomy menu-item-object-category menu-item-125648"><a href="https://www.techcentral.ie/category/beat/">TechBeat</a></li>
<li id="menu-item-129780" class="civil menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129780"><a href="https://www.techcentral.ie/category/blogs/">Blogs</a></li>
</ul></div>    </div><!-- footerLinks -->

<div class="footerLinks2">
    <ul >
        <li><a href="https://www.mediateam.ie/privacypolicy/" target="_blank">Privacy Policy</a></li>
        <li><a href="/sitemap/">Sitemap</a></li>
        <li><a href="/about/">About</a></li>
        <li><a href="/contact/">Contact</a></li>
        <li><a href="/advertise/">Advertise</a></li>

    </ul>
</div>
  <!-- src="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/images/footer.gif"-->
<div id="footerImages" style="text-align:center">
	<a id="footerTC" target="_blank" href="https://techcentral.ie/"><img src="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/images/footerTC.gif" alt="Tech Central" border="0" /></a>
	<a id="footerTf" target="_blank" href="https://www.techfire.ie/"><img src="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/images/footerTF.gif" alt="Tech Fire" border="0" /></a>
	<a id="footerTT" target="_blank" href="https://www.techtrade.ie/"><img src="https://www.techcentral.ie/wp-content/themes/shelflifegonzo/images/footerTT.gif" alt="Tech Trade" border="0" /></a>
	<a id="footerITC" target="_blank" href="http://techawards.ie/"><img src="https://www.techcentral.ie/wp-content/uploads/2019/05/Tech_awards_logo-footer.png" alt="ICT Excellence Awards" border="0" /></a>
	<a id="footerTechPro" target="_blank" href="https://www.techcentral.ie/techpro-magazine/"><img src="https://www.techcentral.ie/wp-content/uploads/2017/01/TechPro-footer.jpg" alt="Tech Pro" border="0" /></a>
	<a id="footerTechBeat" target="_blank" href="https://www.techcentral.ie/techbeat/"><img src="https://www.techcentral.ie/wp-content/uploads/2017/01/TechBeat-footer.jpg" alt="Tech Beat" border="0" /></a>

</div>

<p>Published by Mediateam Ltd., Ireland technology media leader since 1976,<br />
55 Spruce Ave, Sandyford, Dublin 18, A94 N125.</p><br />

<!--<div style="text-align:center"><a href="https://www.mediateam.ie" target="_blank"><img align="Media Team" src="https://www.techcentral.ie/wp-content/uploads/2013/06/mediaTeam.png" /></a></div>-->
    <div id="media_logo"><a href="https://www.mediateam.ie" target="_blank"><img align="Media Team" src="https://www.techcentral.ie/wp-content/uploads/2013/06/mediaTeam.png" /></a></div>


<br /><br />


</footer>
<p id="back-top"><a href="#top"><span></span></a></p>

<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.techcentral.ie\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.techcentral.ie\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.1'></script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.5.0'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.techcentral.ie/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.5.0'></script>
<![endif]-->
<!--[if lt IE 7 ]>
        <script src="https://ajax.googleapis.com/ajax/libs/chrome-frame/1.0.2/CFInstall.min.js"></script>
        <script>window.attachEvent("onload",function(){CFInstall.check({mode:"overlay"})})</script>
	<![endif]-->

</div><!-- /transparent-layer -->








<script src="https://www.google-analytics.com/urchin.js" type="text/javascript"></script>
<script type="text/javascript">
	_uacct = "UA-2173604-2";
	urchinTracker();
</script>
<script type="text/javascript" src="https://www.tcr.tynt.com/javascripts/Tracer.js?user=akoXUqjuar36bLadbiUzgI&amp;s=62"></script>



<!-- Start Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

 (function() {
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "https://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);
  })();

_qevents.push({qacct: "p-4_mtq3u_6wdfu"});

</script>
<noscript>
 <img src="https://www.pixel.quantserve.com/pixel/p-4_mtq3u_6wdfu.gif?labels=_fp.event.Default" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<script type="text/javascript">
window.onload = function(){
    var el = document.querySelector("#PopupSignupForm_1 .mc-closeModal");
    var modal = document.querySelector("#PopupSignupForm_1");
    var modaltwo = document.querySelector("#PopupSignupForm_0");
    var elements = function(){
    modal.style.display = "none";
    modaltwo.style.display = "none";
    el.style.display = "none";
    el.style.display = "none";
    };
    el.onclick = function(){
        modal.style.display = "none";
        modaltwo.style.display = "none";
    };
};
</script>
</body>
</html>